sass使用

发布于 2017-04-27  309 次阅读


sass使用

安装

ruby安装

因为sass依赖于ruby环境,所以装sass之前先确认装了ruby。先导官网下载个ruby 在安装的时候,请勾选Add Ruby executables to your PATH这个选项,添加环境变量,不然以后使用编译软件的时候会提示找不到ruby环境

sass安装

安装完ruby之后,在开始菜单中,找到刚才我们安装的ruby,打开Start Command Prompt with Ruby

然后直接在命令行中输入

gem install sass

按回车键确认,等待一段时间就会提示你sass安装成功。

升级sass版本的命令行为

gem update sass

查看sass版本的命令行为

sass -v

sass安装

配置webstorm中sass

配置

在webstorm中settings中搜索file watchers工具,在此工具中添加一个scss的watcher,按照下图设置各项。点击ok

建个scss文件试试如下图,写个简单的sass代码

会自动生成对应的css文件。如下图:

webstorm中sass编译时目录或内容包含中文字符报错

解决目录带中文问题:

Encoding::CompatibilityError: incompatible character encodings: GBK and UTF-8

打开--trace

出现如下提示信息:filesystem.rb 87行的index

找到文件lib\ruby\gems\2.3.0\gems\sass-3.4.22\lib\sass\importers\filesystem.rb的87行

添加encode("utf-8",'gbk')

测试:

SASS开发环境搭建(webstorm做编辑器) webstorm中sass编译时目录或内容包含中文字符报错http://www.cnblogs.com/chengwb/p/6122132.html


梦想还是要有的,万一实现了呢